Degraded service on Cloud Telephony
Incident Report for Windsor Telecom
Resolved
Our engineers have identified the fault and the service has been fully restored. If you are still experiencing issues on Cloud Telephony please contact support@windsor-telecom.co.uk
Posted Jan 13, 2022 - 10:06 GMT
Investigating
We are currently aware of a call routing fault with our Cloud Telephony service. This is causing some calls to not ring or customers not being able to answer calls. Our engineers are aware of the fault and working to resolve this. We will update the status page as soon as we have further updates.
Posted Jan 13, 2022 - 09:26 GMT
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls).