Windsor Phone - Outage

Incident Report for Windsor Telecom

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 17:43 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 17:05 BST

Investigating

We are currently investigating an issue affecting our API and Customer Portal.

Customers may experience errors or degraded performance when accessing the API or Portal at this time.

We are actively investigating and will provide an update shortly.
Posted Jul 13, 2026 - 15:23 BST
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls, Management Portal, Analytics, Call Manager Plus).