Website & Hosted Issue (Partial Outage)
Incident Report for Windsor Telecom
Resolved
We were experiencing network connection issues this morning which affected the ability to log into portals and make or receive inbound and outbound calls. This has been closely monitored for the last few hours and no other issues have occurred and the network connection is running as it should
Posted Feb 04, 2020 - 15:46 GMT
Investigating
We are currently experiencing issues with our website and internal portal. Some incoming and outbound calls are also affected by the network connection.
This is currently being investigated with our supplier and will endeavor to update you as soon as we have identified the fault.
Posted Feb 04, 2020 - 11:36 GMT
This incident affected: Windsor Hosted (Incoming Calls, Outgoing Calls) and My Windsor (My Windsor Portal).