Cloud Telephony Issue
Incident Report for Windsor Telecom
Resolved
This incident has now been resolved.
There has been no further issues throughout our monitoring period since the system fix was applied.
Posted Nov 27, 2024 - 17:33 GMT
Monitoring
Our engineers have implemented a fix to the service outage and are currently monitoring the platform. We are seeing both inbound and outbound calls flowing as expected at this time.
Posted Nov 27, 2024 - 14:30 GMT
Investigating
A small number of our customers are currently experiencing a service outage on their Xelion phone system.
The outage appears to be intermittently affecting inbound phone calls only.
Our Support Team is actively working with the supplier to resolve this issue and a further update will follow in due course.
Posted Nov 27, 2024 - 12:56 GMT
This incident affected: Cloud Telephony (Incoming Calls).