Inbound and Outbound Calls Failing
Incident Report for Windsor Telecom
Resolved
This incident has been resolved.
Posted Feb 13, 2021 - 11:03 GMT
Monitoring
Our network team have identified the issue and a fix has been implemented.
Calls should now be flowing.
If you run into any further issues - please submit a support ticket with the examples to support@windsor-telecom.co.uk
Posted Feb 12, 2021 - 16:42 GMT
Investigating
We have been notified that there is an issue with incoming and outbound calling on our Windsor Telecom phone system.

We are investigating this issue and we will update again by 17:00.
Posted Feb 12, 2021 - 16:34 GMT
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls).