Toolbox
Incident Report for Windsor Telecom
Resolved
This issue has now been fully resolved.
Posted May 22, 2019 - 10:48 BST
Monitoring
The issue has been fixed and we are monitoring the situation. We will mark this issue as resolved within the next hour.
Posted May 22, 2019 - 10:08 BST
Identified
We have been made aware that some of our customers are experiencing issues making changes to their Toolbox numbers. We are looking into the issue and will update as soon as we know more. Please note that this only affects making changes to your Toolbox numbers, all other services are unaffected.
Posted May 22, 2019 - 09:32 BST
This incident affected: My Windsor (My Windsor Portal).