Horizon Connectivity
Incident Report for Windsor Telecom
Resolved
Further to the last update the issue is now resolved. Please retest and contact us if you are experiencing any ongoing service disruption. Thank you for your patience during the investigation.
Posted Mar 04, 2020 - 09:40 GMT
Investigating
We have been made aware that our customers are experiencing issues on their Horizon Connectivity. Our network are aware of the issue and currently investigating the cause for this incident.
Posted Mar 04, 2020 - 08:55 GMT
This incident affected: Horizon Connectivity (FTTC, Ethernet, ADSL).