Cloud Telephony Degradation
Incident Report for Windsor Telecom
Resolved
The Cloud Telephony service has now been fully restored.
Posted Mar 19, 2021 - 13:17 GMT
Update
We are assisting customers with any ongoing configuration issues.
Posted Mar 19, 2021 - 12:11 GMT
Investigating
We are assisting customers with any ongoing configuration issues.
Posted Mar 19, 2021 - 11:12 GMT
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls, Management Portal).