Cloud Telephony issue
Incident Report for Windsor Telecom
Resolved
This incident has been resolved. If you experience any issues please email support@windsor-telecom.co.uk and one of our engineers will contact you directly.
Posted Sep 27, 2021 - 15:19 BST
Update
We are continuing to monitor for any further issues.
Posted Sep 27, 2021 - 10:55 BST
Monitoring
This morning at 10.30am, we experienced a short outage on our Cloud Telephony service. Our engineers identified the network issue and the service was restored in a matter of minutes. Our engineers are confident that the issue has been fixed and we’re now monitoring the platform to ensure everything is working as it should. If you continue to experience problems we recommend first rebooting your handset; if issues are ongoing please email support@windsor-telecom.co.uk and one of our engineers will contact you directly.
Posted Sep 27, 2021 - 10:54 BST
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls).