MyWindsor access
Incident Report for Windsor Telecom
Resolved
We can now confirm this incident has now been resolved. If you are experiencing any issues, please do not hesitate to contact us on 0333 123 8080.
Posted Feb 27, 2020 - 11:09 GMT
Monitoring
We have identified the issue and are continuing to monitor the situation.
Posted Feb 27, 2020 - 09:40 GMT
Investigating
We have been made aware that our customers are experiencing issues logging onto their MyWindsor portal. We are currently investigating and will endeavour to update you as soon as we have identified the issue.
Posted Feb 27, 2020 - 09:34 GMT
This incident affected: My Windsor (My Windsor Portal, My Windsor Mobile App, API, SMS, Vision Call Statistics, Survey Responses).