Cloud Telephony - Failing Calls
Incident Report for Windsor Telecom
Resolved
All services remain stable and this incident has been resolved.
We will allow call recording processing to catch up slowly and this will be fully caught up by 9am tomorrow.
Our apologies again for the service interruption
Posted Nov 20, 2020 - 17:03 GMT
Update
Services remain stable.
The precautionary processing delay introduced for call recordings remains in place.
An update on this will follow later.
Posted Nov 20, 2020 - 15:23 GMT
Update
Further restoration works has been completed to restore the service.
We have confirmation that users are now back up and registering on our phone system portal.

The delay on processing call recordings will remain in place and we will provide another update on this as soon as possible.
Posted Nov 20, 2020 - 13:41 GMT
Monitoring
Restoration work has reduced the impact on our servers and call volumes are returning strongly.

For the end users who have call recording enabled:
Please note that as a precaution, call recordings will not currently be updating on the Windsor portal but we can confirm calls are still being recorded.
We will be adding them back to the portal as soon as possible so please check back for these later today.

We will continue to monitor the service.
Posted Nov 20, 2020 - 12:12 GMT
Update
High loads on our servers has been identified as part of this problem and restoration work is under way.
We will provided another update within the next hour.
Posted Nov 20, 2020 - 11:46 GMT
Identified
We are working on mitigating and resolving the call failure issues.
Apologies for the extended time taken in dealing with this.
Posted Nov 20, 2020 - 11:21 GMT
Investigating
We have received notification of call failures from a small number of users and are investigating.
A further update will follow within the next half an hour.
Posted Nov 20, 2020 - 10:50 GMT
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls).