Cloud Telephony Issue
Incident Report for Windsor Telecom
Resolved
We’ve been carefully monitoring our cloud telephony for some time and have found no further issues, we therefore believe that this situation has been resolved. If you’re still experiencing any problems, then please email support@windsor-telecom.co.uk so we can contact you to resolve. We thank you for your patience and understanding through this time.
Posted Jun 07, 2021 - 15:16 BST
Monitoring
Service is beginning to return to normal for some customers. We are closely monitoring the situation and will continue to provide updates.
Posted Jun 07, 2021 - 13:35 BST
Update
We are continuing to investigate and will update as soon as we know more.
Posted Jun 07, 2021 - 13:02 BST
Update
We have identified the issue and are currently working to resolve. Further update at 1pm.
Posted Jun 07, 2021 - 12:35 BST
Update
We are continuing to investigate and will update at 12:30.
Posted Jun 07, 2021 - 12:13 BST
Identified
Our Cloud Telephony service is currently experiencing an issue that is limiting some customers' ability to connect to the platform. Our engineers are working to resolve and we'll provide a further update at 12.30pm.
Posted Jun 07, 2021 - 12:12 BST
This incident affected: Cloud Telephony (Outgoing Calls, Incoming Calls).