Inbound call management availability
Incident Report for Windsor Telecom
Resolved
The issues have been fully resolved. Delayed Vision call statistics, call recordings, voicemails and faxes have all resumed normal service.

A full postmortem on this issue will follow in due course.
Posted Nov 14, 2021 - 16:42 GMT
Monitoring
The fix has been implemented and affected services have been restored.

Please note that call recordings, voicemails, missed call alerts and faxes will start to appear in the portal throughout the evening.
Posted Nov 14, 2021 - 16:09 GMT
Identified
We have identified the issue and have begun rolling out a fix. This may take some time to propagate to all services and customers.
Posted Nov 14, 2021 - 14:12 GMT
Update
Inbound call recordings, voicemails, missed call alerts and faxing will also be affected; they will function as normal but will be delayed in appearing in My Windsor.
Posted Nov 14, 2021 - 12:54 GMT
Update
We are continuing to investigate this issue.
Posted Nov 14, 2021 - 12:40 GMT
Update
We are continuing to investigate this issue.
Posted Nov 14, 2021 - 12:37 GMT
Investigating
Inbound call management via the My Windsor portal is currently experiencing issues. Updating inbound call plans are currently unavailable due to said issue.

Vision call statistics are also delayed but no call data will be lost.

The issue is currently under investigation and further updates will be provided in due course.

Please note that the Inbound telephony network is unaffected and calls will continue to route correctly.
Posted Nov 14, 2021 - 11:15 GMT
This incident affected: My Windsor (My Windsor Portal, My Windsor Mobile App, API, Vision Call Statistics), Inbound (Voicemail, Call Recording, Missed Call Alerts), Faxing (Outgoing Faxes), and Cloud Telephony (Management Portal, Call Manager Plus).