Horizon Platform
Incident Report for Windsor Telecom
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 08:24 GMT
Monitoring
Further to the last update, we can confirm that services have now restored and that the issue was down to a 3rd party on our network. We like to thank you for your support during this incident and apologise for the impact caused. We will continue to monitor the service through out the rest of the day.
Posted Nov 14, 2019 - 13:40 GMT
Update
Our network have advised they have identified an issue on a third party network affecting some issues on the Horizon platform. They are continuing to investigate however have advised that some customers are seeing their services restored. A further update will follow at 1.30pm
Posted Nov 14, 2019 - 12:48 GMT
Investigating
We have been made aware that our customers are experiencing issues on the Horizon platform. We are currently investigating this matter with our supplier and will endeavour to update you as soon as we have identified the fault.
Posted Nov 14, 2019 - 12:18 GMT
This incident affected: Horizon (Incoming Calls, Outgoing Calls, Call Recording, Collaborate, Connect).