Missing inbound calls, recordings, voicemails and faxes
Incident Report for Windsor Telecom
Resolved
The missing CDRs have been restored successfully. As previously stated, some of the calls may show in Vision with some routing information missing, however all call recording, voicemail and fax files will start to appear within the My Windsor portal throughout the night.
Posted Jan 13, 2021 - 22:10 GMT
Update
The missing call and file data will has been recovered and will be restored to the portal at 22:00. Unfortunately, some of the calls may show in Vision with some routing information missing, however all call recording, voicemail and fax files will be restored in full.

This recoverable data pertains to calls made between 06:00 and 12:00 today (13th January 2021). All calls outside of this timeframe remain unaffected.
Posted Jan 13, 2021 - 17:06 GMT
Identified
The issue has been identified are we are now working on recovering the missing calls and media files.
Posted Jan 13, 2021 - 16:31 GMT
Investigating
We are currently investigating an issue affecting inbound call statistics not appearing within the My Windsor portal. This issue also affects the visibility of call recordings, voicemails, faxes and survey responses within the My Windsor portal. You should still receive any call recordings and voicemails via email should you have that enabled.

Please note that all affected calls and media files will be available eventually, they are simply unavailable at this time.

We will update as soon this issue evolves.
Posted Jan 13, 2021 - 14:25 GMT
This incident affected: Inbound (Voicemail, Call Recording, Missed Call Alerts, Callback Requests) and My Windsor (Vision Call Statistics, Survey Responses).